Road Bike, Cycling Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a 07 595 Ultra frame set and recently brought it to my LBS for the full build up. The mechanic at the LBS called and said that the left hand side bottom bracket cup would only go in 3/4 of the way, and then totally freeze. He has tried everything even using a tap, but still no luck (the right side threads in just fine). The LBS has tried to contact Look but so far no response. If anyone out there can help I would really appreciate it. The frame is brand new, so my only thought is some kind of factory defect on the left hand side bottom bracket insert.
 

· Registered
Joined
·
95 Posts
ugly_steve said:
I have a 07 595 Ultra frame set and recently brought it to my LBS for the full build up. The mechanic at the LBS called and said that the left hand side bottom bracket cup would only go in 3/4 of the way, and then totally freeze. He has tried everything even using a tap, but still no luck (the right side threads in just fine). The LBS has tried to contact Look but so far no response. If anyone out there can help I would really appreciate it. The frame is brand new, so my only thought is some kind of factory defect on the left hand side bottom bracket insert.
With the risk of asking too basic a question you are using an English threaded bottom bracket correct? Or perhaps it's the actual BB that is defective and not the BB shell on the Look frame. If the mechanic has another left side BB cup in his shop maybe he can attempt to thread that one onto your frame to either rule out or confirm that theory.
 

· Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Before the BB was trashed he (the mechanic) tried it on a different frame, and it went into the bb shell just fine. I also made sure that it was an english BB, so we did eliminate that possibility early on. Thus the final conclusion that it is the frame.

I am just worried that if it does turn out to be the frame I will be waiting a long time for the replacement due to several other posts on this forum. I am just wondering if anyone else has had a similar problem, and how Look resolved the issue. Or if someone has a way to contact Look directly, since all of the calls we have placed so far have not been returned.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top