Road Bike, Cycling Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
391 Posts
Discussion Starter · #1 ·
So I have some new-to-me 2015 Red HRD shifters and had to get new housings so I could run them internally (needed to be much longer). My front brake bled perfectly and has a super awesome lever feel and I nailed it on the first try (using Sram's video as my instructions). When I went to do the rear installation/bleed, I get a completely different result. At the final step of pressurizing the system and then removing the lever bleed adapter, hydraulic fluid comes pouring out of the bleed port and gets everywhere, and a lot of it! The first time it actually shot out of the bleed port. The lever also has a much longer throw to engage the rotor, so much so that I'm almost hitting the bar with the brake lever. It's also odd to me since the lever doesn't feel spongy or like there's air in the system. (I've bled many a Hope and Shimano brake for my mountain bikes). Any help or advice is appreciated, thanks!

bike info:
Orbea Avant
Red 22 shifters, calipers- pads are plenty thick/lots of life left
Hope 160mm front rotor
Avid 140mm rear rotor (5 years old, so maybe its thinner causing the problem??)

I also used the Sram bleed kit adapters and bleed block for road disc brakes, though not the Pro syringes.
 

·
Registered
Joined
·
172 Posts
Hi, I just did the bleed of my Force CX1 setup (similar to Red HRD but Force) and while I had no issues with the fluid pouring out of any port the final result is similar to yours - perfect front brake engagement and a longer throw on the rear. If I did not have the front setup much better I'd think the rear is good. I am planning on redoing the rear. will re-post once completed
 

·
Registered
Joined
·
172 Posts
OK, redone the bleed job on the rear. There were a couple of bubble of air and all went super smooth. End effect is slightly better than what it was before. I think the diff between the front and rear on the stand is my imagination. Braking while riding is perfect on front and rear. Again, no issues with fluid shooting out. Perhaps you over pressurized the system before removal of the shifter port attached syringe. ???
 

·
Registered
Joined
·
391 Posts
Discussion Starter · #4 ·
Man, late reply to my own thread, but I haven't touched the rear brake since posting and now I have a ton of lever play before engaging. So much so that unless I hold my finger on the lever 100% of the time, the rattling of the freeplay drives me insane. Will try to rebleed and update again. I've googled and searched but it seems that I'm the only owner of Red hydro to have this problem!!
 
1 - 4 of 4 Posts
Top